beta levels after frozen embryo transfer

I got my positive blood test today. Yeayyyyy!!! Test done after 9 days. Beta is 57. The doctor said this is good
For FET. It seems low though. They also started me on oral progesterone even though I have been on the vaginal since b4 the transfer. I'm so nervous because the last transfer with fresh embryos was fine . Positive beta's for the 1st 3 tests then the pregnancy just didn't materialize. I had to have a Dnc.

Can some of you that have had FET tell me what your beta's were through the 1st few weeks of a BFP?

I'd really appreciate it.

Thanks!
REPLIES
By: BabyBumpUser
Member since Nov 03, 2010
Posted: on Dec 01, 2010
Hi! I have had 2 successful fresh IVF cycles and my first betas were 52 & 76 after 3 day transfers.. This time we used out remaining frozen embryos and my beta at 9 days post transfer of 3 blastocysts was 254 (I believe) and the second one was done 12 days post transfer was 948.. Since my previous IVF betas had never been that high we were pretty sure there was more than one.. I'm currently 12 wks with twins.. Your number sounds like my first two ivf's of which I have two beautiful daughters from. Good luck and keep us posted:)
By: BabyBumpUser
Member since Oct 03, 2010
Posted: on Dec 02, 2010
My first beta at 14 days was 467 & more than doubled both following tests. Currently 15 weeks pg with a singleton after an Aug FET.
By: BabyBumpUser
Member since Oct 03, 2010
Posted: on Dec 02, 2010
Best of luck to you!!!
By: BabyBumpUser
Member since Nov 21, 2010
Posted: on Dec 02, 2010
This is really crazy, my beta in June with my 1st FET was 7.6!! 3 days after it was 87.... I did loose my little one after 12 weeks.. I am so hoping to get a BFP on 12/10!! Good luck to you ladies!!!!
By: BabyBumpUser
Member since Dec 02, 2010
Posted: on Dec 02, 2010
Had my FET 11/15, 1st beta 9 days later and it was 67, next beta 2 days layer was 168, doc was happy with the numbers, I go for ultrasound 12/10, we transferred 2, 6 day embies. Had miscarriage in June, 1st IVF.
By: BabyBumpUser
Member since Nov 28, 2010
Posted: on Dec 02, 2010
Thanks for the replies, good luck , and your in my prayers! I'll keep you posted and you do the same! Dct apt tomorrow.
By: BabyBumpUser
Member since Nov 28, 2010
Posted: on Dec 03, 2010
Just came back from the dct. Beta was 129 from the previous 57 . Dct is happy...progesterone was at 4127 from the previous 1257. She said this is good as well. On the ultra sound we saw what may be the start oh the gestational sac! She told me not to get to excited because it's really early and it could have been anything. But I am excited !!! I'm still on bed rest.... but, whatever it takes !
By: BabyBumpUser
Member since Nov 03, 2010
Posted: on Dec 03, 2010
Congrats sounds like your little one is going strong:)
By: BabyBumpUser
Member since Nov 21, 2010
Posted: on Dec 03, 2010
So happy for you!! Stay in bed!!!
By: BabyBumpUser
Member since Dec 02, 2010
Posted: on Dec 12, 2010
Had my u/s yesterday and it looks like we are having one baby, baby's heart rate was at 125 bpm, doc was very happy with that and says it leaves us in 2-3% miscarriage stats.
By: BabyBumpUser
Member since Oct 20, 2010
Posted: on Dec 21, 2010
Waaw girls u bring hope to us
My first ivf was 84 on day 14p3dt and after 2 days levels were 72 doctor said ur misscarrying and stop medicense
Now i feel so bad because i think that he supposed to wait

My seconed ivf on day 8p5dt 23 and 2 days later it was below 5

Now this is my third and now am 2dp5dt and hoope this is the one
By: BabyBumpUser
Member since Nov 21, 2010
Posted: on Dec 21, 2010
Ok, I had a FET on 11/28 with 2 embryos. My first beta was 17.6, 2nd 14.6, 3rd 58.5, 4th 190. I go again tomorrow for another and a ultrasound! There is always hope!! Good luck to you all!
By: BabyBumpUser
Member since Nov 21, 2010
Posted: on Dec 21, 2010
Before the 190 I also had 85.6!! Oops!!!
By: BabyBumpUser
Member since Oct 20, 2010
Posted: on Dec 22, 2010
Congrats kim
And good luck in ur ultrasound

Mobile View | Full Site